Filter refreshing broken  ** Completed **

Moderator: abstr

Post Reply
borism
Posts: 2
Joined: Fri Jul 31, 2020 8:00 pm

Filter refreshing broken

Post by borism » Fri Jul 31, 2020 8:10 pm

Hi Dan,
everything was great until RC 7, but something looks terribly wrong with filters now. I can't reset filter, so I can't get to my tasks as they are not visible.
Any idea how to roll back to RC 6 or anything like that?

After some testing: actually, refresh filter doesn't work, so you can't change filter value by selecting value 'any' in the toolbar filter field.
However, "clear filter" does work, and setting filter value from the menu item "view/filter" also does work. Ugly thing is that after you change filter filed in the toolbar (to any date, for example) after refresh nothing happened. Also, after changing some value in "option" in the filter toolbar, filter value in the toolbar filter field will rollback to the previous value, so you basically can't remove filter value in the toolbar only. As mentioned before, clear filter will help in this case.

Probably easy enough to fix, but as under time pressure, I almost got stroked.

User avatar
abstr
Site Admin
Posts: 368
Joined: Sun Jul 28, 2019 12:22 pm

Re: 8.0 RC 7

Post by abstr » Sat Aug 01, 2020 2:31 am

Sorry for the inconvenience borism.

You can revert to 8.0.RC6 here.

User avatar
abstr
Site Admin
Posts: 368
Joined: Sun Jul 28, 2019 12:22 pm

Re: Filter refreshing broken  ** Completed **

Post by abstr » Sat Aug 01, 2020 3:06 am

Fixed in 8.0.RC8.

borism
Posts: 2
Joined: Fri Jul 31, 2020 8:00 pm

Re: Filter refreshing broken

Post by borism » Sat Aug 01, 2020 3:49 pm

Hi Dan,

Everything works fine now in RC8.

Thank's for your fast response.

Regards, Boris

Post Reply