Custom Task Attribute Features don't stick Topic is solved

Moderator: abstr

Locked
Ryan
Posts: 142
Joined: Mon Aug 03, 2020 2:47 am

Custom Task Attribute Features don't stick

Post by Ryan » Sat Jul 03, 2021 9:20 pm

Dan I'm stumped on this so I am not going to call it a bug in case I am missing something. I'll leave that call to you.

I tried it on a fresh install of 8.0.22.0 and these are the screen shots. I can also post the file(s) if you need them.

I create a Custom Task Attribute called "Projects"

Image

I click "OK" on the dialog above.

When I reopen that dialog, the "Features" field is blank no matter which features were checked, all features are unchecked (apparently it is happening when OK is clicked in the previous step).

Image

I am experiencing other unexpected behavior with this custom attribute as well, but I think one at a time is the best approach. This is the most obvious one. And maybe the other ones are related to it in some way.

User avatar
abstr
Site Admin
Posts: 366
Joined: Sun Jul 28, 2019 12:22 pm

Re: Custom Task Attribute Features don't stick

Post by abstr » Sun Jul 04, 2021 7:35 am

Hi Ryan

The first thing I noticed was that the 'Tasklist:' field at the top of the dialog is empty which should only be possible for a brand-new, unsaved tasklist.

But even trying that did not allow me to reproduce the issue.

Could you attach your preferences please?

Ryan
Posts: 142
Joined: Mon Aug 03, 2020 2:47 am

Re: Custom Task Attribute Features don't stick

Post by Ryan » Sun Jul 04, 2021 1:11 pm

Thank you for your response Dan.

The empty 'Tasklist:' field was a good observation, I had not thought of trying saving the file first. So I just now tried saving it and then setting the Features, but had the same problem.

By preferences do you mean the ToDoList.ini file? I've attached it here hoping that is what you need.
Attachments
Custom Task Attribute Features.zip
(6.27 KiB) Downloaded 16 times

User avatar
abstr
Site Admin
Posts: 366
Joined: Sun Jul 28, 2019 12:22 pm

Re: Custom Task Attribute Features don't stick

Post by abstr » Mon Jul 05, 2021 12:52 am

Yes, that was the right file.

Could you also attach the tasklist itself? (I didn't ask before)

Ryan
Posts: 142
Joined: Mon Aug 03, 2020 2:47 am

Re: Custom Task Attribute Features don't stick

Post by Ryan » Mon Jul 05, 2021 1:04 am

Yes of course Dan. This is very strange. I have no idea why it happens and can't even provide any helpful clues at this point.

Here is the file.
Custom Task Attribute Features-TaskList.zip
(727 Bytes) Downloaded 8 times

User avatar
abstr
Site Admin
Posts: 366
Joined: Sun Jul 28, 2019 12:22 pm

Re: Custom Task Attribute Features don't stick

Post by abstr » Sun Jul 11, 2021 2:28 am

Fixed in 8.0.23

Locked